Support
Center
 Running Linux Kernel 3.x, the drivers say it's incompatible
Solution

Compiling against Linux Kernel 3.x


Issue

When compiling against the Linux Kernel version 3.x.x, you receive an error stating that "Your Linux kernel is incompatible"

Background

The Makefile check for Kernel version was written when the Linux 2.6.x tree was expected to last for the foreseeable future. As such, the Kernel version check was hard-coded around the 2.6 tree and does not properly handle the 3.x.x version numbering.
The Rhino PCI drivers ARE compatible with the 3.x.x Linux kernel.

Workaround

Edit the Makefile's line 232 and remove the _checkKernel prerequisite from the _checks target
From
_checks: _checkDAHDI _checkKernel
To
_checks: _checkDAHDI

Resolution

This has been fixed as of version 0.99.6b1 (currently in beta testing)

Keywords

Linux, 3.x, incompatible, kernel, error, compiling, Makefile



 Login [Lost Password] 
Email:
Password:
Remember Me:
 
 Search
 Article Options